My system is a stock 4-year old 2.4 Ghz Pentium 4 Dell Dimension 8250 (XP Home), upgraded with:

  • Hauppage WinTV PVR-250
  • Hauppage WinTV PVR-150
  • Windows XP MCE 2005
  • Nvidia GeForce 6600GT
  • Cicero Firewire Card
  • Microsoft Digital Media Pro keyboard (USB)
  • Acer AL1715 LCD monitor (connected through DVI)
  • 768 MB RAM (it's RDRAM, and expensive, thus I only added 512 extra to the stock 256)

Well, I didn’t really “upgrade” but basically did a clean install of Vista Ultimate. I have MCE 2005, but I also purchased Snapstream BeyondTV because I really don’t like being constrained to the .dvr-ms format – especially if I want to edit some TV shows. The kicker also was their “ShowSqueeze” function to recompress the mpeg to divx format, a real space saver. Also, their commercial skip function is incredible also, a big time saver. The trouble was, I was occassionally getting audio hiss from my second TV tuner, and I did not know how to get rid of it. This problem has frequently spoiled some of my recordings. I figured by re-installing, Vista MCE would have default drivers that will solve my problem.

I was surprised that the Vista Ultimate install went smoothly – I only had to enter the product key and add some login info, and that was it. There was one hiccup though – my keyboard was not being recognized. Strange, since it’s a Microsoft keyboard! Luckily, there were accessibility options later where I could use the on-screen keyboard to login. I played around with Vista a bit to check whether everything was working – and activated it, which went pretty smoothly. I still had problems with my Digital Media Pro keyboard (fairly new) not being recognized, even when I installed the latest Intellitype software for Vista (downloaded from microsoft.com/hardware). I tried all USB ports, but Vista kept showing the error popup “USB Device Not Recognized”. Frustrating – but luckily I had an older Microsoft Internet Keyboard Pro (7 years old).

Vista MCE works great, and drivers for my Hauppauge cards were automatically applied to the devices. The only device trouble I had was trying to find drivers for my Plustek 1212U Scanner (over 7 years old). I thought I could use the Agfa Snapscan 1212U drivers (perhaps it is a re-branded Plustek), but no dice. I even installed the Vuescan software and used their generic scanners.inf file and tried to install their generic Plustek scanner device. The driver installed fine, but of course my scanner wouldn’t work at all. Oh well, I think after 7 years maybe I can afford to upgrade my scanner – either that or I can pair it up with an older XP machine. SnapStream BeyondTV works well, with their 4.6 version. Although video from the tuners is definitely slower than when on XP, since my Nvidia PureVideo drivers do not work on Vista – thus I am using the default rendering from the tuner cards.

I didn’t play much with the apps, although its interesting that Windows Movie Maker can edit dvr-ms files now. Played with some Texas Hold’em (downloaded from Microsoft Update), tried out Windows Mail, Calendar and Photo Gallery , Contacts – nothing interesting there. Vista SideBar was ho-hum: even if I used it, it probably will end up the same as my usage of OS X Dashboard: very infrequent. I didn’t like that I couldn’t resize their RSS gadget vertically. The “Network” is pretty cool – my D-Link DIR-655 router was detected and also the Snapstream BeyondTV web service. If I had other Vista machines this would help tremendously, instead of having to memorize IP addresses to go to their configuration pages. Even my APC UPS was “detected” properly when I plugged in its USB cable, and battery level can be viewed in the Power Options. ReadyBoost is intriguing – I don’t have a fast enough USB key, so I ordered a ReadyBoost ready 2GB USB key to test this out. I’m not going to spend a premium on getting more RDRAM for my system. UAC as expected is annoying – I have to endure this just to delete some file I created? Nanny-soft!

So there you have it, I only had two device problems: one did not have a Vista driver, and the other is inexplicable, since its a Microsoft product. For the keyboard: it’s not a problem with my USB ports, since other devices can be plugged into any of the ports and they are recognized immediately. Aero works great, but even with the latest Nvidia (beta) drivers I get an annoying flicker when Vista goes through the Secure Desktop for UAC. I’m sure that will be fixed with the final drivers. The DreamScene content (for Vista Ultimate) is nice: although I can’t imagine turning it on for my single-core system – I don’t even have hyper-threading on this CPU. For those of you that don’t know, the DreamScene content is basically high-definition videos that can act as your (animated) desktop background. I really like the (water) stream one. If I had a multi-core/multi-processor system I would definitely turn on DreamScene content.

Ok, enough about Vista. After the initial excitement of installing something new wore off – I’m back to my 17” Macbook Pro, running OS X 10.4.9. Occassionally I will RDC to the Vista machine, I think :)